Sounds not playing.

Started by pthomas745
over 4 years ago

I'm not getting any sound from the current Mexico data, which is all I can say since I've been away from the project for a long time. (Anyone remember me? :) )

Running Win 7, neither Firefox nor Chrome work: If I click the play arrow it changes to a pause button, but the audio does not play and the yellow tracker line does not move.

The tutorial works just fine for me, though, and I notice that this object plays fine for me also, so it probably is something specific to more recent data or specific batches:

Whereas the following objects do not work for me:

The objects that play correctly also display correctly on the object screen.

The object pages for objects that do not work show a broken image icon in the corner and do not display the spectrogram, like this (clicking the "show image" button does show the spectrogram image, however):


over 4 years ago

Also, quick question. I know the data might not be quite as good if we don't have the audio, but is it okay for us to classify anyway if the audio isn't working?

about 4 years ago

First, the hashtag: #soundproblems2016

Okay, I took a crack at fixing it, and managed to get classifying working for me again - but NOT the broken objects linked in my previous post, which still show the same "broken image" icon and won't play. Here's what I did (I have Firefox on Win 7):

  1. First, I did a clean reinstall of Flash Player, following the instructions here:

  2. That didn't change anything, so I did another clean reinstall, but this time I used an archived version of Flash Player (went all the way back to 10.3!!) but that didn't work either. (So I did a clean install of the newest version again (lots of computer restarts, just to be sure I was doing things right).

  3. I tried wiping all Zooniverse and Bat Detective cookies via Firefox menu: Tools>Options>Privacy>"remove individual cookies" (I searched for "zoo" and "bat" and deleted all of the relevant cookies I could see)

  4. When that didn't work, I deleted ALL browser cookies: Tools>Options>Privacy>"clear your recent history" (In the dropdown menu above I chose "Everything" and unchecked all boxes except for "Cookies", then pressed the "Clear Now" button) Still nothing. In fact, the play button actually stopped switching from an arrow to a pause button when I clicked it for some reason after the previous step.

  5. Finally, I looked up how to delete the cache for a specific website in Firefox: (WARNING - This actually clears the cookies and remembered passwords for the site as well!) In the Menu bar for Firefox: History > Show All History > [Use search bar in upper right of the popup window:] type "" > Right click on the item in the list that has that URL (maybe any Bat Detective URL would work, I just figured the basic domain name would be most direct if it mattered). > Select "Forget about this site" from the context menu > Go to and see if classifying works for you now.

Finally it works!

Given that it was the last step that fixed it, you might want to go through my steps in reverse order ;) (I kind of started with the most extreme steps, but I figured others had already tried the more basic trick and they hadn't worked - of course we might not all be getting the exact same error here). But I can't say for sure whether any of those other steps helped resolve it also. Still the new object pages aren't working. I assume either a Flash update or a Bat Detectives interface change (or both?) has caused these problems to crop up suddenly? Or maybe something more arcane and unexpected with the site?

I hope this helps someone!

Please Log In to make comments.